TresCom Forums

TresCom : The Trespasser Fan Gateway...
It is currently Sat Sep 21, 2019 7:53 am

All times are UTC




Post new topic Reply to topic  [ 12 posts ] 
Author Message
 Post subject: lagging
PostPosted: Wed May 08, 2019 1:07 pm 
Offline
Dinosaur egg
Dinosaur egg

Joined: Wed May 08, 2019 12:25 pm
Posts: 1
help game it's so laging my settings https://zapodaj.net/40a635dcef607.png.html
I'm have all patch installed


Top
 Profile  
 
 Post subject: Re: lagging
PostPosted: Wed May 08, 2019 3:16 pm 
Offline
-=TresCom Website Manager=-
-=TresCom Website Manager=-
User avatar

Joined: Fri Jun 24, 2005 9:40 pm
Posts: 3761
Location: Sweden
Welcome to TresCom! :)

Try install the CE patch: viewtopic.php?f=6&t=10674

It should help to resolve issues on modern OS. Hopefully that help.

The engine is unstable so even on modern PC is will lag with a high resolution. Also try "hardware" mode, it will be the one above that is in your language text.

_________________
"...there used to be more benches, but InGen's workers removed them during the evacuation in the name of framerate."

"The main laboratory and administrative buildings. This is where we made our work, where the real magic trick happen. When they are in need of height fixing, they'll come here." - Hammond


Top
 Profile  
 
 Post subject: Re: lagging
PostPosted: Wed May 08, 2019 5:30 pm 
Offline
T-Rex
T-Rex
User avatar

Joined: Thu Feb 20, 2014 9:13 pm
Posts: 2853
Location: Canada, eh?
I literally just logged in to post about this when I saw your post. Have any of the other regulars had this problem?

I got a new PC a couple of days ago and of course immediately booted up Trespasser (because you need a GTX 1080 to play Tres, right? :P ). Anyway, I loaded beach just as a test...and the game immediately started lagging. This was not the case on my old PC - I only had problems with lag when there were a LOT of objects on-screen - yet this new PC is superior in every way and should be running better if anything. I've tried fiddling with the CE settings and haven't found a solution yet, especially since the strange thing is, the lag only occurs when I'm in very specific spots. At first I thought it was the water, but no, it seems to occur somewhat randomly.
Here's an example: The initial spot where Anne starts on the beach chops my framerate in half. You look around and the game is choppy. Then you walk forward 3 steps...and POOF! the lag is gone. It's as if something that the game has loaded into its memory is what's destroying the framerate rather than any particular object. It also seems this PC loads terrain textures slower as well, even though I'm running Tres off an SSHD whereas before I had it on an HDD, but it still ran poorly on the HDD. There must be something specific that's wrong in the settings, or maybe Trespasser just doesn't like my setup.
I have yet to try many fan levels outside of the regular game, but I can already tell you that RTJP~Helipad is running far worse than it was before. I had 45 FPS average throughout the level and 30ish around the VC, now I get something more like 20 in random places, even the middle of nowhere where I haven't placed any objects.

I'm wondering if we should ask Lee about this since it could just be one wrong CE setting that I'm not noticing. I could try ATX but I don't even have any ATX executables installed anymore to try since the old PC wouldn't let me run them. :sick:
Luckily I have the old PC hooked up to my TV now in case of LAN parties, so it might turn out that I just have to use the old one for Trespasser, but I'd really like to get it running properly on here. There's no hardware-related reason it should be running slower as every single other game I've tried - old or new - runs at a minimum constant 60 FPS.

_________________
Image
Return to Jurassic Park: A Trespasser Mod - Forum or ModDB | Trespasser HD | My Release Thread | Level Reviews


Top
 Profile  
 
 Post subject: Re: lagging
PostPosted: Wed May 08, 2019 5:54 pm 
Offline
-=TresCom Website Manager=-
-=TresCom Website Manager=-
User avatar

Joined: Fri Jun 24, 2005 9:40 pm
Posts: 3761
Location: Sweden
I bought a new PC a few weeks ago (GTX 1060) and it has no lag in BE at the start. I mainly mod and do not play as much so I don't know if I have more issues now.

I think you are lucky if you get 60 FPS out of Trespasser. I never got more than 30-ish even on a modern PC a few years ago. Is it possible it could rather be CPU related than GPU? Some games tend to have ever more weird physics with a faster CPU for example.

Also with Trespasser I've experience it can behave even different on the same PC but after a reinstall.

_________________
"...there used to be more benches, but InGen's workers removed them during the evacuation in the name of framerate."

"The main laboratory and administrative buildings. This is where we made our work, where the real magic trick happen. When they are in need of height fixing, they'll come here." - Hammond


Top
 Profile  
 
 Post subject: Re: lagging
PostPosted: Tue May 14, 2019 2:26 am 
Offline
T-Rex Killer
T-Rex Killer
User avatar

Joined: Mon Dec 06, 2004 5:21 pm
Posts: 11740
Location: Portland, OR
Actually TI, I was noticing a trend that Tres will work worse on better hardware sometimes... For example my latest two levels which crashed for some of you guys but was almost flawless on mine. I really think it has to do with the hardware trying harder at rendering the game, like the "bar" is set higher, and that in turn decreases a dimension of performance.
I would say, try altering the graphical settings in the drivers to increase performance..

_________________
Image
Image Image T-Script Reference / Trespasser Millennium / JP Dark Secrets / Tres File Box


Top
 Profile  
 
 Post subject: Re: lagging
PostPosted: Tue May 14, 2019 5:13 pm 
Offline
T-Rex Killer
T-Rex Killer
User avatar

Joined: Thu Apr 24, 2003 11:20 pm
Posts: 11510
Location: Lima, Peru
Draconisaurus wrote:
I would say, try altering the graphical settings in the drivers to increase performance..

That didn't make any difference with your levels when I tried it, I'm afraid.

_________________
Visit The Carnivores Saga - a forum devoted to modding Action Forms' Carnivores, Carnivores 2 and Carnivores: Ice Age games
Tres WIP: updated T-Script Reference and File Formats documents
Sound name listings for the Demo (build 117), Retail (build 116), Beta 103, Beta 99, Beta 97, Beta 96, Build 55, PC Gamer Alpha (build 32) and E3 1998 Alpha (build 22) TPA files


Top
 Profile  
 
 Post subject: Re: lagging
PostPosted: Tue May 14, 2019 5:43 pm 
Offline
T-Rex Killer
T-Rex Killer
User avatar

Joined: Mon Dec 06, 2004 5:21 pm
Posts: 11740
Location: Portland, OR
Really? *hits explorer windowsill* Damn..

_________________
Image
Image Image T-Script Reference / Trespasser Millennium / JP Dark Secrets / Tres File Box


Top
 Profile  
 
 Post subject: Re: lagging
PostPosted: Tue May 28, 2019 3:49 am 
Offline
Dinosaur egg
Dinosaur egg

Joined: Tue May 28, 2019 3:46 am
Posts: 5
So, here's the thing. I'm having trouble getting Trespasser to work too. When I used Trespass CE, it ran flawlessly, however, I NEED to be able to use ATX instead of CE for all the added functionality. Is there a way to use both? And if not, how can I stop the massive memory leak from leeching all my frames on the normal ATX version?


Top
 Profile  
 
 Post subject: Re: lagging
PostPosted: Tue May 28, 2019 4:10 am 
Offline
-=TresCom Website Manager=-
-=TresCom Website Manager=-
User avatar

Joined: Fri Jun 24, 2005 9:40 pm
Posts: 3761
Location: Sweden
Hi kenvin, welcome to TresCom!

ATX and CE can both be used in the same installation. I am not aware of a memory leak in the ATX version. If that is the case, it would probably be an original issue within the game. CE uses DirectX 9 unlike ATX and the original version. Don't expect the best FPS with the original game (including ATX) as ATX don't fix any engine related issues.

_________________
"...there used to be more benches, but InGen's workers removed them during the evacuation in the name of framerate."

"The main laboratory and administrative buildings. This is where we made our work, where the real magic trick happen. When they are in need of height fixing, they'll come here." - Hammond


Top
 Profile  
 
 Post subject: Re: lagging
PostPosted: Tue May 28, 2019 12:36 pm 
Offline
Dinosaur egg
Dinosaur egg

Joined: Tue May 28, 2019 3:46 am
Posts: 5
So they can be both used at the same time? How do you do this? When I extracted the both of them to the root folder, only the .exe that I launch will be in effect. It will only let me use either or, pretty much. Instructions on how to use the both of them please?


Top
 Profile  
 
 Post subject: Re: lagging
PostPosted: Tue May 28, 2019 2:41 pm 
Offline
-=TresCom Website Manager=-
-=TresCom Website Manager=-
User avatar

Joined: Fri Jun 24, 2005 9:40 pm
Posts: 3761
Location: Sweden
kenvin wrote:
So they can be both used at the same time? How do you do this? When I extracted the both of them to the root folder, only the .exe that I launch will be in effect. It will only let me use either or, pretty much. Instructions on how to use the both of them please?


I thought you meant in the same installation. Running both won't work. However, most of the ATX function (except a few) work in CE.

_________________
"...there used to be more benches, but InGen's workers removed them during the evacuation in the name of framerate."

"The main laboratory and administrative buildings. This is where we made our work, where the real magic trick happen. When they are in need of height fixing, they'll come here." - Hammond


Top
 Profile  
 
 Post subject: Re: lagging
PostPosted: Wed May 29, 2019 7:57 pm 
Offline
T-Rex Killer
T-Rex Killer
User avatar

Joined: Mon Dec 06, 2004 5:21 pm
Posts: 11740
Location: Portland, OR
Welcome, to Tressic Parker. 8) Sorry for the bad news about ATX for you. It does have some nice features such as jumping raptors. Sadly for now just use whichever engine best suits the level you're playing.

_________________
Image
Image Image T-Script Reference / Trespasser Millennium / JP Dark Secrets / Tres File Box


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB® Forum Software © phpBB Group